Simplelogin Email System Outage
Incident Report for Misins
Resolved
This Outage has been resolved.
Posted May 08, 2024 - 12:23 AEST
Investigating
We are aware of problem with our Email provider Simplelogin that affects Logging in to accounts and delayed email.
Posted May 08, 2024 - 12:15 AEST
This incident affected: Markus Misins Email System.